jan 022005
 

Tot nu toe gaat het testen met Apache redelijk voorspoedig. Ik moet zeggen dat ik het gisterenavond bijna opgegeven had. Wat ik ook probeerde, ik kreeg het gebruik van RewriteRule in .htaccess op de server hier maar niet aan de praat. Terwijl ik toch hetzelfde deed als op de edublogs-server.
Reden: ik had alleen het hekje (#) voor LoadModule rewrite_module modules/mod_rewrite.so weggehaald, en niet ook voor AddModule mod_rewrite.c
(ja, als je het weet, dan is het érg duidelijk!)
Zoals Rino ook aangaf, was het probleem van de ontbrekende “default.asp” bestanden redelijk gemakkelijk op te lossen.
Ik heb inmiddels de default-setting in httpd.cnf voor de ‘root’ van elke virtual host staan op:

Options FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all

In één van de mappen wil ik dat het wel aan staat, maar daar mag niet iedereen kunnen bladeren, dus daar gebruik ik een .htaccess-bestand met:

Options Indexes FollowSymLinks MultiViews

Omdat ik enkele bestanden en mappen op het moment met wachtwoorden vanuit windows beveiligd heb (o.a. die met Options Indexes) en dat nu ook in Apache moest werken, ben ik met authenticatie in .htaccess aan de slag gegaan:

AuthType Basic
AuthName “Gorissen website”
AuthUserFile X:/pwd/passwords
Require valid-user

Ik ben even begonnen met Basic-authenticatie, dat is het niveau dat ik in Firefox op dit moment ook had, Digest-authenticatie staat op het TODO-lijstje.

Deel dit bericht:

  2 reacties aan “Testen met Apache #2 – Rewrite problemen”

Reacties (2)
  1. Ik zag dat Gideon al een pagina over RewriteRule gemaakt had, dus heb ik het maar weer een WikiWoord gemaakt. :-)

  2. One is glad to be of service. :)

Sorry, het reactieformulier is momenteel gesloten.